You'll notice
Artifact shared databases now warn when they are full or nearing capacity, suggesting you prune or aggregate documents.
A new helper builds usage warning messages for an artifact's shared database, alerting when it is full ("writes that create a document will fail until some are deleted") or over a threshold percentage full, advising to prune or aggregate existing documents rather than creating one document per item.