You'll notice
When sync is refused the turn proceeds with stale files and a notice says fresh ones should arrive on a later turn.
When a directory-sync upload the machine announced can't be waited for because the sync service is refusing the session, the turn now proceeds using stale files instead of stalling, and a dedicated in-turn notice tells the model/user that the up-to-date files are expected to arrive on a later turn.